FEMLAB starting example
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GOVERNING EQUATIONS

This is 2 multiphysics model because it involves more than one kind of physics. The
incompressible Navier-Stokes equations from fluid dynamics works together with a
heat transfer equation. There are four unknown field variables (dependent variables):

 The velocity ficld components, u and v
* The pressure, p
« The temperature, T

They are all related through bidirectional multiphysics couplings.



z
Q)
g
D

dJu
£ it

V-w=0

5

with the following variables:
e uis the veloaty field.

* pisthe pressure.

* Fisa volume force.

* p s the Hluid density

* 1) is the dynamic viscosity

V is the vector differential operator.

+p{u-"?:u=—'\7p+n'¥zu+F



1
(D
Q)
~—
i
O
D)

aT i
Peyzr + V- (-&VT+pc,Tu) = @

where Cp is the hear capacity of the fluid, and p is fluid density. The expression within
the brackets is the hear flux vector. @ represents a source term. The hear flux vecror
contains a diffusive and a convectve term, where the latter is proportional to the
velocity field, u. The velocity field comes from the incompressible Navier-Stokes
cquation. This mcans that we have a onc-way multiphysics coupling from the fluid ficld

to the energy transport by convection.
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To build a model in FEMLAB using the above equations, use two application modes:
the Incompressible Navier-Stokes application mode for fluid flow, and the Convection
and Conduction applicanon mode for heat transfer. The multiphysics couplings enter
directly into the physics settings in the application modes.

In this model, the equations are coupled through the F and @ terms. First, add free
convection to the momentum balance with the Boussinesg approximation. This
approximation ignores variations in density with temperature, except that the
variations give nse to a buoyancy force lifting the fluid. This force enters the F term in
the incompressible Navier-Stokes equations.
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MODEL NAVIGATOR
Starting FEMLAB opens the Model Navigator:
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Use the following steps to create a new multiphysics model:

Click the New tab, and check that 20 is selected in the Space dimension list. The space
dimension must always be selected first, because the available application modes
vary depending on the space dimension.

Click the Multiphysics button to open the secion where you can create a
multiphysics model.

In the application modes list on the left, open the Fluid Dynamics folder and click
Incompressible Navier-Stokes.

The default application mode name is ns, and the default names of the dependent
variables arc u, v, and p, for the velocity components in the x- and y-direction and

the pressure. The default finite clements for the Incompressible Navier-Stokes

application mode are mixed second-order and first-order triangular Lagrange
elemments, Lagrange p2-p1 elements.



4 Click Add. This aq;_f:ptﬂ the setrings in the Application mode name, Dependent
variables, and Element cdit fields and transfers the Incom pressible Navier-Stokes
application mode to the list of application modes in Multiphysics section.

5 In the applicanon modes list, open the Heat Transfer folder and click Convection
and Conduction.

6 Click Add again to add the Convection and Conduction applicadon mode to the
model with the default variable name, T, and element type (second-order Lagrange
elements),

7 Click OK to close the Model Navigator and create a new model.

At this point, FEMLAB opens up in the Convection and Conduction application
mode. You can always find out which applicaton mode that is active. Its name appcears
in the title bar of the FEMLAB window.
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OPTIONS AND SETTINGS

Laterin this model you will need the fluid propertes of the water, the temperatures at
the inlet and on the surface of the heating tubes, and the inlet velocity. It is convenient

to enter this data as constants in the Constants dialog box. In this model, all values are
given in 81 units.

I From the Options menu, choose Constants.
2 First add the density of the fluid:

Enter rho( in the Name field. Press the Tab key to move the cursor to the Expression
field and enter 1e3. Theyalue is saved when you press Enter, click Apply, or otherwise

& |
leave the Expression ficld.

3 Continue by adding the remaining propertics

4 When you have entered all constants, click OK.
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| From Options menu, choose Axes/Grid Settings

2 In the Axes/Grid Settings dialog box, enter -0.01, 0.01, -0.01, and 0.05 in the x

min, x max, y min, and y max edit fields, respectively

3 Click the Grid tab and then click to clear the Aute check box. Enter 0. 005 in both
the x spacing and y spacing edit fields.

4 Click OK to close the dialog box and apply the sertings.
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I Draw a rectangle of width 0.005 and height 0.04, with the lower left corner at the
origin. Click the Draw Rectangle toolbar button. It is the first button on the draw
toolbar, on the lcft side of the drawing arca. Then click at (0,0 using the left mouse

button, and drag the mouse to (0.005,0.04). Release the burton.

Draw Centered Elipse

L lololalo

2 Draw a carcle with radius 0.005 centered at (0,0.015). Click the fourth burton on
the Draw toolbar, Draw Centered Ellipse. Then, using the »ight mouse button, click
at (0,0.015) and drag the mouse in any direction, keeping the button down, untl
the circle has a radius of 0.005. Using the right mouse button constrains the ellipse

to a arcle.



3 The desired radius of the circle is not 0.005, however, but is 0.0025. To fix this,
double-click the circle object or select Object Properties from the Draw menu. In the
Circle dialog box, enter 0.0025 as Radius and click OK.
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4 Select both the circle and the rectangle. Either draw a rubber-band box around both
them, or press the shortcut key Ctri+A to sclect all objects.
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Boundary Conditions
Specify the boundary conditions, first for the Convection and Conduction mode and

then for the Incompressible Navier-Stokes mode.

I From the Physics menu, choose Boundary Settings. This opens the Boundary Setting
dialog box and transfers FEMLAB to the boundaryselection mode. The contents of
this dialog box varies depending on the application mode.

2 Srtart by insulating all boundaries. This is the default boundary condition, so you do

not need w change anything,

3 Sclect the inflow boundary by clicking at the corresponding edge in the geometry
or by selecting boundary number 2 in the Boundary selection list. Select
Temperature in the Boundary conditions list and enter Tin in the Temperature cdit
field.



4 Sclect the heater that exists along boundaries 6 and 7 from the Boundary selection
list. Then select Temperature in the Boundary conditions list and enter Theat in the
Temperature cdit field.

Boundary 3ettings - Convection and Conduction [cc)
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5 Click the outflow boundary (boundary number 4) and sclect Convective flux in
thc Boundary conditions list.

6 Click Apply to confirm the settings for the Convection and Conduction application
mode.



7 Switch to the Incompressible Navier-Stokes application mode by selecting this
mode from the Multiphysics menu. You can now open another Boundary Settings
dialog box from the Physies menu.

8 Press Ctri+A 1o sclect all boundaries in the list and then select the Slip/symmetry

condition from the Boundary conditions list.
9 For the inflow boundary, select boundary 2 and then choose Inflow/Outflow velocity

in the Boundary conditions list. Enter vin in the y-velocity edit ficld (leave the x

velocity at 0) .

Boundary Settings - lncompressible Mavier -Stokes {(ns)
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10 Continue by sclecting the outflow boundary (boundary number 4). In the Boundary
conditions list, sclcct Normal flow/Pressure. Leave the pressure at 0.

Il Finally select boundaries 6 and 7 and then select the No slip boundary conditon.
Click OK to confirm vour choices and close the dialog box,
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In the Subdomain Settings dialog box you can also sct initial values. The Navier-Stokes
equations are nonlinear and therefore benefit from an educated guess as an initial
solution to the nonlinear solver. In some cases, a good initial value might be necessary
for the model to converge. The initial values are also used as initial conditions for the
tume-dependent solver.

Depending on the application mode, the coefficients in the governing cquations can
be interpreted as material properties, forces, and sources and sinks. You specify all of
them in the Subdomain Settings dialog box. This time start with the Incompressible

Navier-Stokes application mode and continue on to the Convection and Conduction

applicaton mode.

I Choose Subdomain Settings from thc Subdemain menu to open the Subdomain

settings dialog box and put the user interface in the subdomain selecion mode.



2 Seclect the single subdomain, number 1, and use the already defined constants to set
the density and the viscosity. Enter rho0 and mu in the Density and Dynamic viscosity

ficlds, respectvely. P

Subdomain Seltings - Incomprassible Mavier Stokes (ns)
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3 To model the effect of temperarure on the density of the fluid as a buoyancy force
in the y direction, enter alpha0*g0*rho0* (T-Tin) in the Volume force, y-dir. edit
field (F). Remember that T is the dependent variable from the Convection and

Conduction application mode. Notce that an extended edit field displays the entire
expression.



I Click the Init rab in the Subdomain Settings dialog box. Set the initial valuc v(ty) o
vin.

Subdomain Settings - Incompriessible Novier-Stokes (as)
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Continue with the subdomain settings for the Convection and Conduction application
mode:

¥
I Usc the Multiphysics menu to switch to the Convection and Conduction application

mode,



2 Open the Subdomain Settings dialog box for the Conveetion and Conduction
application mode.

subrdomain Settings - Conmvection and Conduction (co)
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3 Enter rho0, cp, and k¢ in the Density, Heat capacity, and Thermal eonductivity
(isotropic) edit fields, respectively.

4 Enter uand v in the x-velocity and y-velocity cdit ficlds, respectively. They are the
dependent variables for the velocity components from the Incompressible
Navier-Stokes application mode, which account for the convective transport of heat.



5 The temperature also needs an initial value. Use the inlet temperature as the starting

temperature in the entire domain. Click the Init tab and enter Tin in the T(tg) field.

Then click OK to confirm all settings and close the dialog box.
i1
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To create a default mesh, enter mesh mode directly or click the Initial Mesh button. If
vou need a different mesh resolution or require the mesh to be denser in some parts
of the geometry than in others, you can use the settings in the Mesh Parameters dialog
box and other commands in the Mesh menu.

If you trust the default settings, you can proceed directly to solving the model.
FEMLAB then creates a mesh when you click the Solve button. It is, however, good
practice to inspect the mesh before solving, because the mesh density and quality affect
the solution time, convergence, and accuracy.

In this model, use a predefined setting for a fine mesh:

| From the Mesh menu, choose Mesh Parameters.
2 In the Mesh Parameters dialog box, select Fine in the Predefined mesh sizes list.
3 Click OK.

4 Initialize the default mesh clicking the Initialize Mesh burton on the Main toolbar.



COMPUTING THE SOLUTION
The required nonlinear solver is the default solver, so you start the solver directly.

Click the Solve burton. Notice the solution progress window where vou can monitor
and stop the solution process. The solution converges quickly in this case.

As soon as the solution is ready, FEMLAB displays a default plot. In this case, you get
a surface plot of the velocity field.

POSTPROCESSING AND YISUALIZATION

In postprocessing mode you can select from many different plot types and set
parameters for the different plots. Using the postprocessing utilities you can visualize
the solution variables, their derivatives, and the space coordinates. Many frequently
used expressions are predefined as postprocessing variables, directly available from lists
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I Click the Plot Parameters button on the main toolbar. This opens the Plot
Parameters dialog box on the General page.

Plot Pasnawtent

Sohsion @ e (phesey I | degrees 2 To obtain a surface plot with overlaid arrows, slect the Surface and Arrow check
[ cortour ] Blemart ssiction -
] Boumciry e b i nci boxes.
e H s o 3 Click the Surface tab.
[ Stresmine [ |
DOlswostimene | giotomet Flae £ | 4 Under Surface data, sclect Temperature in the Predefined quantities list.
[ perormed snape [ M rough piots -
(=) Goometey sages § Click the Arrow tab,

6 Sclect Velocity field inthe Predefined quantities list

7 Under Arrow positioning, enter 10 and 15 in the x points and y points cdit ficlds,
respectively.

e o cas BT T e 5 8 Finally, under Arrow parameters, click the Color button to choose a suitable arrow

[ Smoctheg.. | [ mwetaas. |

color, for example, white.

o [Ccancet | [ asmv | 9 Click OK.




Integrating to Find the Mean Temperature

Because both the velocity and temperature vary along the outlet at the top, yvou mus
use additional postprocessing to get the mean temperature at the exit. The bulk
temperature, or the “cup mixing temperature™ is the temperature that the fluid has i
it is collected in a cup at the outflow and is properly mixed. For this 2D example, thy
cup mixing temperature is given by the following expression on boundary 4 (the

outlet }:

j':rudx

Ao Iuﬂﬂx

To obuin the denominator, choose Boundary Integration from the Post menu.
Select boundarv 4.

Selecr y-velocity in the Predefined quantities ficld.

Click Apply.

N ok W W

The values of the denominator is displaved in the message log:

Value of integral: 2.5e-5, Expression: v, Boundary: 4.

Copy the value by sclecting it and pressing Ctri+C.

6 In the Boundary Integration dialog box, type T*v/. Then paste the denominator at

the end of the expression for the integrand to form T*v/2.5e-5 in the Expression
edit field. This will compute the resulting mean temperature.

7 Click OK. The result is displayed in the message log.

You should get a mean temperature of roughly 293.75 K, that is, a temperature rise of
approximately 0.75 K between inlet and outlet.

SAYVING THE MODEL

To save the model o a file:

I In the File menu, choose Save.

2 Browse to sclect a file or enter a file name for the model file.
3 Chck Save.

The default format is a FEMLAB model file with exrension .f1. Usec this format to
quickly save and open FEMLAR models.
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In the Physics menu, point to Equation System and then Subdomain Settings. This opens

S

the Subdomain Settings dialog box for the full system of equations.

The underlying equation appears in the upper left corner, and the edit fields and tabs
now correspond to equation coefficients rather than material properties. The
interpretation of the coefficients depend on whether FEMLAB currently uses the
coefficient form, general form, or weak form to describe a generic PDE. See “Using
the PDE Modes™ in the Application and Modeling Guide. Muluphysics problems are
normally based on the general form, and it is this formulation that you can see at the
rop of the dialog box.

FEMLAR normally solves multiphysics problems directly as a coupled PDE system. In
general form, symbolic differentiation provides the exact stiffness matrixor Jacobian

of the complete system. You can see the result on the ¢, a, al, and be tabs.

There is also an extra tab, Weak, where you can specify additional terms to cquations
on the weak PDE form. Weak coefficients are available on all levels: subdomains,
boundaries, edges, and points. Use them to implement, for instance, explicit
streamline diffusion, weak constraints, linc sources, and point sources, respectively.
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To find the application mode variables, click the right-most tab, Variables. The

Variables page lists their names and how they are defined. Edit the expressions to
change the predefined expressions
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